$re = '/ [ \t\n\x0B\f\r]*\{[ \t\n\x0B\f\r]*((.|\r|\n)*".*"[ \t\n\x0B\f\r]*:[ \t\n\x0B\f\r]*".*"(.|\r|\n)*){0}[ \t\n\x0B\f\r]*\}[ \t\n\x0B\f\r]*/m';
$str = '{
"location1": "project:bq_dataset.bq_table1",
"location10": "project:bq_dataset.bq_table10",
"location17": "project:bq_dataset.bq_table17"
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);