const regex = / [ \t\n\x0B\f\r]*\{[ \t\n\x0B\f\r]*((.|\r|\n)*".*"[ \t\n\x0B\f\r]*:[ \t\n\x0B\f\r]*".*"(.|\r|\n)*){0}[ \t\n\x0B\f\r]*\}[ \t\n\x0B\f\r]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' [ \\t\\n\\x0B\\f\\r]*\\{[ \\t\\n\\x0B\\f\\r]*((.|\\r|\\n)*".*"[ \\t\\n\\x0B\\f\\r]*:[ \\t\\n\\x0B\\f\\r]*".*"(.|\\r|\\n)*){0}[ \\t\\n\\x0B\\f\\r]*\\}[ \\t\\n\\x0B\\f\\r]*', 'gm')
const str = `{
"location1": "project:bq_dataset.bq_table1",
"location10": "project:bq_dataset.bq_table10",
"location17": "project:bq_dataset.bq_table17"
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}