#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\{\{(?:\s|\n)*(?!(?:'|\s|\n))(.*')(?:\s|\n)*(\|(?:\s|\n)+translate)\b"
Local $sString = "anyText' | translate" & @CRLF & _
"" & @CRLF & _
"<other text or tags>{{ anyText' | translate" & @CRLF & _
"" & @CRLF & _
"{{" & @CRLF & _
"anyText' | translate" & @CRLF & _
"" & @CRLF & _
"{{ test anyText'" & @CRLF & _
" | translate"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")