import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{(?:\\s|\\n)*(?!(?:'|\\s|\\n))(.*')(?:\\s|\\n)*(\\|(?:\\s|\\n)+translate)\\b";
final String string = "anyText' | translate\n\n"
+ "<other text or tags>{{ anyText' | translate\n\n"
+ "{{\n"
+ "anyText' | translate\n\n"
+ "{{ test anyText'\n"
+ " | translate";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}