const regex = /\{\{(?:\s|\n)*(?!(?:'|\s|\n))(.*')(?:\s|\n)*(\|(?:\s|\n)+translate)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{(?:\\s|\\n)*(?!(?:\'|\\s|\\n))(.*\')(?:\\s|\\n)*(\\|(?:\\s|\\n)+translate)\\b', 'gm')
const str = `anyText' | translate
<other text or tags>{{ anyText' | translate
{{
anyText' | translate
{{ test anyText'
| translate`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}