$re = '/\{\{(?:\s|\n)*(?!(?:\'|\s|\n))(.*\')(?:\s|\n)*(\|(?:\s|\n)+translate)\b/m';
$str = 'anyText\' | translate
<other text or tags>{{ anyText\' | translate
{{
anyText\' | translate
{{ test anyText\'
| translate';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);