import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-?)P(?=.)((\\d*)Y)?((\\d+)M)?((\\d*)D)?(T(?=\\d)(\\d+H)?(([\\d]+)M)?(([\\d]+(?:\\.\\d+))S)?)?$";
final String string = "P2Y6M5DT12H35M30S\n"
+ "P1DT2H\n"
+ "P20M\n"
+ "PT20M\n"
+ "P0Y20M0D\n"
+ "P0Y\n"
+ "-P60D\n"
+ "PT1M30.5S\n"
+ "--\n"
+ "P-20M\n"
+ "P20MT\n"
+ "P1YM5D\n"
+ "P15.5Y\n"
+ "P1D2H\n"
+ "1Y2M\n"
+ "P2M1Y\n"
+ "P\n"
+ "PT15.S";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}