use strict;
my $str = 'P2Y6M5DT12H35M30S
P1DT2H
P20M
PT20M
P0Y20M0D
P0Y
-P60D
PT1M30.5S
--
P-20M
P20MT
P1YM5D
P15.5Y
P1D2H
1Y2M
P2M1Y
P
PT15.S';
my $regex = qr/^(-?)P(?=.)((\d*)Y)?((\d+)M)?((\d*)D)?(T(?=\d)(\d+H)?(([\d]+)M)?(([\d]+(?:\.\d+))S)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}