const regex = /^(-?)P(?=.)((\d*)Y)?((\d+)M)?((\d*)D)?(T(?=\d)(\d+H)?(([\d]+)M)?(([\d]+(?:\.\d+))S)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?)P(?=.)((\\d*)Y)?((\\d+)M)?((\\d*)D)?(T(?=\\d)(\\d+H)?(([\\d]+)M)?(([\\d]+(?:\\.\\d+))S)?)?$', 'gm')
const str = `P2Y6M5DT12H35M30S
P1DT2H
P20M
PT20M
P0Y20M0D
P0Y
-P60D
PT1M30.5S
--
P-20M
P20MT
P1YM5D
P15.5Y
P1D2H
1Y2M
P2M1Y
P
PT15.S`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}