$re = '/^(-?)P(?=.)((\d*)Y)?((\d+)M)?((\d*)D)?(T(?=\d)(\d+H)?(([\d]+)M)?(([\d]+(?:\.\d+))S)?)?$/m';
$str = 'P2Y6M5DT12H35M30S
P1DT2H
P20M
PT20M
P0Y20M0D
P0Y
-P60D
PT1M30.5S
--
P-20M
P20MT
P1YM5D
P15.5Y
P1D2H
1Y2M
P2M1Y
P
PT15.S';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);