#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^i-[a-f0-9]{8}(?:[a-f0-9]{9})?$"
Local $sString = "i-ed3a2f7a" & @CRLF & _
"i-096e0bec99b504f82" & @CRLF & _
"i-0cad9e810fbd12f4f" & @CRLF & _
"e123g12" & @CRLF & _
"i-1fz5645m" & @CRLF & _
"i-abcdeffh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")