re = /^i-[a-f0-9]{8}(?:[a-f0-9]{9})?$/m
str = 'i-ed3a2f7a
i-096e0bec99b504f82
i-0cad9e810fbd12f4f
e123g12
i-1fz5645m
i-abcdeffh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end