using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^i-[a-f0-9]{8}(?:[a-f0-9]{9})?$";
string input = @"i-ed3a2f7a
i-096e0bec99b504f82
i-0cad9e810fbd12f4f
e123g12
i-1fz5645m
i-abcdeffh";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}