package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^i-[a-f0-9]{8}(?:[a-f0-9]{9})?$`)
var str = `i-ed3a2f7a
i-096e0bec99b504f82
i-0cad9e810fbd12f4f
e123g12
i-1fz5645m
i-abcdeffh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}