using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<authors>[a-zA-Z ,.&]+)\((?P<year>\d{4})\)\.(?P<title>[\w \-:]+)[,.](?P<publication>[\w \-:]+)[,. ]+(?P<volume>[0-9]+)?[,. p]*(?=(?P<index>[0-9–\-]+)\.$)?";
string input = @"Athey, S., & Imbens, G. (2016). Recursive partitioning for heterogeneous causal- effects. Proceedings of the National Academy of Sciences, 113, 7353–7360.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}