import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<authors>[a-zA-Z ,.&]+)\\((?P<year>\\d{4})\\)\\.(?P<title>[\\w \\-:]+)[,.](?P<publication>[\\w \\-:]+)[,. ]+(?P<volume>[0-9]+)?[,. p]*(?=(?P<index>[0-9–\\-]+)\\.$)?";
final String string = "Athey, S., & Imbens, G. (2016). Recursive partitioning for heterogeneous causal- effects. Proceedings of the National Academy of Sciences, 113, 7353–7360.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}