import re
regex = re.compile(r"(?P<authors>[a-zA-Z ,.&]+)\((?P<year>\d{4})\)\.(?P<title>[\w \-:]+)[,.](?P<publication>[\w \-:]+)[,. ]+(?P<volume>[0-9]+)?[,. p]*(?=(?P<index>[0-9–\-]+)\.$)?")
test_str = "Athey, S., & Imbens, G. (2016). Recursive partitioning for heterogeneous causal- effects. Proceedings of the National Academy of Sciences, 113, 7353–7360."
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")