re = /(?P<authors>[a-zA-Z ,.&]+)\((?P<year>\d{4})\)\.(?P<title>[\w \-:]+)[,.](?P<publication>[\w \-:]+)[,. ]+(?P<volume>[0-9]+)?[,. p]*(?=(?P<index>[0-9–\-]+)\.$)?/
str = 'Athey, S., & Imbens, G. (2016). Recursive partitioning for heterogeneous causal- effects. Proceedings of the National Academy of Sciences, 113, 7353–7360.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end