using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z][a-z0-9\-]+$";
string input = @"123341241231512313123
asd1234124
asdw-fawtaw-dwae
A-sdwqw
ADsdwdw
asd.dwqwr.qwr.d
sdwq-sdwa-r_wr
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}