import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z][a-z0-9\\-]+$";
final String string = "123341241231512313123\n"
+ "asd1234124\n"
+ "asdw-fawtaw-dwae\n"
+ "A-sdwqw\n"
+ "ADsdwdw\n"
+ "asd.dwqwr.qwr.d\n"
+ "sdwq-sdwa-r_wr\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}