const regex = /^[a-z][a-z0-9\-]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z][a-z0-9\\-]+$', 'gm')
const str = `123341241231512313123
asd1234124
asdw-fawtaw-dwae
A-sdwqw
ADsdwdw
asd.dwqwr.qwr.d
sdwq-sdwa-r_wr
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}