$re = '/^[a-z][a-z0-9\-]+$/m';
$str = '123341241231512313123
asd1234124
asdw-fawtaw-dwae
A-sdwqw
ADsdwdw
asd.dwqwr.qwr.d
sdwq-sdwa-r_wr
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);