# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d*)(\d{3})/$1.$2/g;t' <<< "89302500
1260840
218580"