using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*)(\d{3})";
string substitution = @"$1.$2";
string input = @"89302500
1260840
218580";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}