import Foundation
let pattern = #"(\d*)(\d{3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
89302500
1260840
218580
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)