use strict;
my $str = '89302500
1260840
218580';
my $regex = qr/(\d*)(\d{3})/p;
my $subst = '$1.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";