import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=((?:\\([A-Z0-9]+\\)|\\d){2,}).*\\1)";
final String string = "(2)2(6)2(6)2(2)2(8)\n"
+ "(G)8(8)(G)4(C)(G)8(8)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}