re = /(?=((?:\([A-Z0-9]+\)|\d){2,}).*\1)/
str = '(2)2(6)2(6)2(2)2(8)
(G)8(8)(G)4(C)(G)8(8)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end