import re
regex = re.compile(r"(?=((?:\([A-Z0-9]+\)|\d){2,}).*\1)")
test_str = ("(2)2(6)2(6)2(2)2(8)\n"
"(G)8(8)(G)4(C)(G)8(8)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")