$re = '/(?=((?:\([A-Z0-9]+\)|\d){2,}).*\1)/';
$str = '(2)2(6)2(6)2(2)2(8)
(G)8(8)(G)4(C)(G)8(8)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);