#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<!--FOO-->((?:\n|.)*?)<!--BAR-->"
Local $sString = "<!--FOO-->" & @CRLF & _
" some text" & @CRLF & _
"<!--BAR-->" & @CRLF & _
"" & @CRLF & _
"some other text" & @CRLF & _
"" & @CRLF & _
"<!--FOO-->" & @CRLF & _
"some more text" & @CRLF & _
"<!--BAR-->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")