import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--FOO-->((?:\\n|.)*?)<!--BAR-->";
final String string = "<!--FOO-->\n"
+ " some text\n"
+ "<!--BAR-->\n\n"
+ "some other text\n\n"
+ "<!--FOO-->\n"
+ "some more text\n"
+ "<!--BAR-->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}