import re
regex = re.compile(r"<!--FOO-->((?:\n|.)*?)<!--BAR-->")
test_str = ("<!--FOO-->\n"
" some text\n"
"<!--BAR-->\n\n"
"some other text\n\n"
"<!--FOO-->\n"
"some more text\n"
"<!--BAR-->")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")