# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*\.com)\\/[^\\/]+(\\/prod[^\_]*\\/p\.prod).*/\1\2/si;t' <<< "http://www.bergdorfgoodman.com/Ippolita-18k-Gold-Rock-Candy-Mini-Single-Square-Pendant-Necklace/prod108010011/p.prod#.U75MVqY-PtS"