re = /(.*\.com)\/[^\/]+(\/prod[^\_]*\/p\.prod).*/i
str = 'http://www.bergdorfgoodman.com/Ippolita-18k-Gold-Rock-Candy-Mini-Single-Square-Pendant-Necklace/prod108010011/p.prod#.U75MVqY-PtS'
subst = '\\1\\2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result