use strict;
my $str = 'http://www.bergdorfgoodman.com/Ippolita-18k-Gold-Rock-Candy-Mini-Single-Square-Pendant-Necklace/prod108010011/p.prod#.U75MVqY-PtS';
my $regex = qr/(.*\.com)\/[^\/]+(\/prod[^\_]*\/p\.prod).*/sip;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";