import re
regex = re.compile(r"^(?:(?!.*LT circa).+\n)*(?:(?!LT circa).)*LT circa\s+(\d\d\.\d\d.\d{4})(?!(?:.+\n)*.*LT circa)")
test_str = ("Metall-Notierung 464,95 EUR 100 KG\n"
"* LT circa 21.04.2020 2 x 500 M Einwegtrommel 400x 150x 404mm\n"
"* LT circa 17.05.2020 2 x 500 M Einwegtrommel 400x 150x 404mm\n"
"Zolltarifnummer 80464995")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")