package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,3})`)
var str = `123456789123456789
1234567891234567892
12345678912345678933`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}