$re = '/(\d{1,3})/';
$str = '123456789123456789
1234567891234567892
12345678912345678933';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);