re = /(\d{1,3})/
str = '123456789123456789
1234567891234567892
12345678912345678933'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end