const regex = /(\d{1,3})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,3})', 'g')
const str = `123456789123456789
1234567891234567892
12345678912345678933`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}