using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(=|<|>|!=)\s*(-?\d+|'[^']+')";
string input = @"SELECT * WHERE field1=5 // OK
SELECT * WHERE field1= 5 // OK
SELECT * WHERE field1< -2 // OK
SELECT * WHERE field1='5' // OK
SELECT * WHERE field1=a // NOT OK since a is not a integer
SELECT * WHERE field1!='a' // OK
SELECT * WHERE field1='a // NOT OK - missing back apostrophe";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}