import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(=|<|>|!=)\\s*(-?\\d+|'[^']+')";
final String string = "SELECT * WHERE field1=5 // OK\n"
+ "SELECT * WHERE field1= 5 // OK\n"
+ "SELECT * WHERE field1< -2 // OK\n"
+ "SELECT * WHERE field1='5' // OK\n"
+ "SELECT * WHERE field1=a // NOT OK since a is not a integer\n"
+ "SELECT * WHERE field1!='a' // OK\n"
+ "SELECT * WHERE field1='a // NOT OK - missing back apostrophe";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}