$re = '/.*(=|<|>|!=)\s*(-?\d+|\'[^\']+\')/';
$str = 'SELECT * WHERE field1=5 // OK
SELECT * WHERE field1= 5 // OK
SELECT * WHERE field1< -2 // OK
SELECT * WHERE field1=\'5\' // OK
SELECT * WHERE field1=a // NOT OK since a is not a integer
SELECT * WHERE field1!=\'a\' // OK
SELECT * WHERE field1=\'a // NOT OK - missing back apostrophe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);