re = /.*(=|<|>|!=)\s*(-?\d+|'[^']+')/
str = 'SELECT * WHERE field1=5 // OK
SELECT * WHERE field1= 5 // OK
SELECT * WHERE field1< -2 // OK
SELECT * WHERE field1=\'5\' // OK
SELECT * WHERE field1=a // NOT OK since a is not a integer
SELECT * WHERE field1!=\'a\' // OK
SELECT * WHERE field1=\'a // NOT OK - missing back apostrophe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end