#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<!--(?!\s*?end-readmore-item\s*-->)[\s\S]*?-->"
Local $sString = "<div class="collapsible-item-body" data-defaulttext="Further text">Further " & @CRLF & _
"text</div>" & @CRLF & _
"<!-- end-readmore-item --></div>" & @CRLF & _
"</div>" & @CRLF & _
" <!-- -->" & @CRLF & _
"it only should match with <!-- --> but it's selecting everything except <!-- " & @CRLF & _
"end-readmore-item -->" & @CRLF & _
"the usage of this is gonna be to remove all the HTML comments except <!-- " & @CRLF & _
"end-readmore-item -->" & @CRLF & _
"<!-- Different comment -->" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")