re = /<!--(?!\s*?end-readmore-item\s*-->)[\s\S]*?-->/m
str = '<div class="collapsible-item-body" data-defaulttext="Further text">Further
text</div>
<!-- end-readmore-item --></div>
</div>
<!-- -->
it only should match with <!-- --> but it\'s selecting everything except <!--
end-readmore-item -->
the usage of this is gonna be to remove all the HTML comments except <!--
end-readmore-item -->
<!-- Different comment -->
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end