import re
regex = re.compile(r"<!--(?!\s*?end-readmore-item\s*-->)[\s\S]*?-->", flags=re.MULTILINE)
test_str = ("<div class=\"collapsible-item-body\" data-defaulttext=\"Further text\">Further \n"
"text</div>\n"
"<!-- end-readmore-item --></div>\n"
"</div>\n"
" <!-- -->\n"
"it only should match with <!-- --> but it's selecting everything except <!-- \n"
"end-readmore-item -->\n"
"the usage of this is gonna be to remove all the HTML comments except <!-- \n"
"end-readmore-item -->\n"
"<!-- Different comment -->\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")