using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^FIXTEST_([A-Za-z0-9]+)\s+([0-9]+)\/tcp\s+#\s*([A-Za-z0-9.]+):([0-9]+)\s*";
string input = @"FIXTEST_XYZ 23040/tcp # 127.0.0.1:23040";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}