const regex = /^FIXTEST_([A-Za-z0-9]+)\s+([0-9]+)\/tcp\s+#\s*([A-Za-z0-9.]+):([0-9]+)\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^FIXTEST_([A-Za-z0-9]+)\\s+([0-9]+)\\\/tcp\\s+#\\s*([A-Za-z0-9.]+):([0-9]+)\\s*', 'g')
const str = `FIXTEST_XYZ 23040/tcp # 127.0.0.1:23040`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}